Vulnerability · Published Jun 20, 2025 · Assigned by Wordfence
CVE-2025-4102Beaver Builder Plugin (Starter Version) <= 2.9.1 - Authenticated (Administrator+) Arbitrary File Upload
High 7.2
In plain English
A high-severity unrestricted file upload in Beaver Builder Plugin (Starter Version) from The Beaver Builder Team. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities).
Official description
The Beaver Builder Plugin (Starter Version) plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'save_enabled_icons' function in all versions up to, and including, 2.9.1. This makes it possible for authenticated attackers, with Administrator-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. The vulnerability was partially patched in version 2.9.1.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| The Beaver Builder Team | Beaver Builder Plugin (Starter Version) | 0 – through 2.9.1 |
Weakness: CWE-434 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H