Vulnerability · Published May 17, 2025 · Assigned by Wordfence
CVE-2025-3527EventON - WordPress Virtual Event Calendar Plugin <= 4.9.6 - Missing Authorization to Authenticated (Subscriber+) Stored Cross-Site Scripting
Medium 6.4
In plain English
A medium-severity missing authorization in EventON (Pro) - WordPress Virtual Event Calendar Plugin from EventON. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities).
Official description
The EventON Pro plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check in the 'assets/lib/settings/settings.js' file in all versions up to, and including, 4.9.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 4.9.6.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| EventON | EventON (Pro) - WordPress Virtual Event Calendar Plugin | 0 – through 4.9.6 |
Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N