Vulnerability · Published Apr 16, 2025 · Assigned by GitHub_M

CVE-2025-32791Permission policy information leakage in Backstage permission system

Medium 4.3

In plain English

A medium-severity security flaw in backstage from backstage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.3%top 78.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The Backstage Scaffolder plugin houses types and utilities for building scaffolder-related modules. A vulnerability in the Backstage permission plugin backend allows callers to extract some information about the conditional decisions returned by the permission policy installed in the permission backend. If the permission system is not in use or if the installed permission policy does not use conditional decisions, there is no impact. This issue has been patched in version 0.6.0 of the permissions backend. A workaround includes having administrators of the permission policies ensure that they are crafted in such a way that conditional decisions do not contain any sensitive information.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@backstage/plugin-permission-backend0.6.0GHSA-f8j4-p5cr-p777

Affected products (as reported)

VendorProductVersions
backstage backstage < 0.6.0

Weakness: CWE-213 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

References