Vulnerability · Published Apr 30, 2025 · Assigned by GitHub_M
CVE-2025-32777Volcano Scheduler Denial of Service via Unbounded Response from Elastic Service/extender Plugin
High 8.2
In plain English
A high-severity resource allocation without limits in volcano from volcano-sh. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Volcano is a Kubernetes-native batch scheduling system. Prior to versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2, attacker compromise of either the Elastic service or the extender plugin can cause denial of service of the scheduler. This is a privilege escalation, because Volcano users may run their Elastic service and extender plugins in separate pods or nodes from the scheduler. In the Kubernetes security model, node isolation is a security boundary, and as such an attacker is able to cross that boundary in Volcano's case if they have compromised either the vulnerable services or the pod/node in which they are deployed. The scheduler will become unavailable to other users and workloads in the cluster. The scheduler will either crash with an unrecoverable OOM panic or freeze while consuming excessive amounts of memory. This issue has been patched in versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | volcano.sh/volcano | 1.9.1 | GHSA-hg79-fw4p-25p8 |
| Go | volcano.sh/volcano | 1.10.2 | GHSA-hg79-fw4p-25p8 |
| Go | volcano.sh/volcano | 1.11.0-network-topology-preview.3 | GHSA-hg79-fw4p-25p8 |
| Go | volcano.sh/volcano | 1.11.2 | GHSA-hg79-fw4p-25p8 |
| Go | volcano.sh/volcano | 1.12.0-alpha.2 | GHSA-hg79-fw4p-25p8 |
| Go | volcano.sh/volcano | 1.10.2, 1.11.0-network-topology-preview.3, 1.11.2, 1.12.0-alpha.2, 1.9.1 | GO-2025-3656 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| volcano-sh | volcano | >= 1.11.0, < 1.11.2>= 1.10.0-alpha.0, < 1.10.2< 1.9.1>= 1.11.0-network-topology-preview.0, < 1.11.0-network-topology-preview.3>= 1.12.0-alpha.0, < 1.12.0-alpha.2 |
Weakness: CWE-770 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/volcano-sh/volcano/security/advisories/GHSA-hg79-fw4p-25p8 x_refsource_CONFIRM
- https://github.com/volcano-sh/volcano/releases/tag/v1.10.2 x_refsource_MISC
- https://github.com/volcano-sh/volcano/releases/tag/v1.11.0-network-topology-preview.3 x_refsource_MISC
- https://github.com/volcano-sh/volcano/releases/tag/v1.11.2 x_refsource_MISC
- https://github.com/volcano-sh/volcano/releases/tag/v1.12.0-alpha.2 x_refsource_MISC
- https://github.com/volcano-sh/volcano/releases/tag/v1.9.1 x_refsource_MISC