Actively exploited · Published Apr 16, 2025 · Assigned by GitHub_M

CVE-2025-32433Erlang/OTP SSH Vulnerable to Pre-Authentication RCE

Critical 10.0 Exploited

In plain English

A critical-severity missing authentication in otp from erlang. Attackers are actively exploiting it in the wild (listed by CISA on June 9, 2025). The chance it is exploited in the next 30 days is estimated at 98.9% (higher than 99.9% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)98.9%top 0.1% of all CVEs
Exploited in the wildYesCISA KEV since Jun 9, 2025
Attack tooling2Metasploit, Public PoC

CISA guidance

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Federal agencies must remediate by Jun 30, 2025.

Official description

Erlang/OTP is a set of libraries for the Erlang programming language. Prior to versions OTP-27.3.3, OTP-26.2.5.11, and OTP-25.3.2.20, a SSH server may allow an attacker to perform unauthenticated remote code execution (RCE). By exploiting a flaw in SSH protocol message handling, a malicious actor could gain unauthorized access to affected systems and execute arbitrary commands without valid credentials. This issue is patched in versions OTP-27.3.3, OTP-26.2.5.11, and OTP-25.3.2.20. A temporary workaround involves disabling the SSH server or to prevent access via firewall rules.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.21erlang26.2.5.11-r0ALPINE-CVE-2025-32433
Debian:12erlang1:25.2.3+dfsg-1+deb12u1DSA-5906-1
Debian:12erlang1:25.2.3+dfsg-1+deb12u1DEBIAN-CVE-2025-32433
Debian:13erlang1:27.3.3+dfsg-1DEBIAN-CVE-2025-32433
Debian:14erlang1:27.3.3+dfsg-1DEBIAN-CVE-2025-32433
Ubuntu:22.04:LTSerlang1:24.2.1+dfsg-1ubuntu0.4USN-7443-1
Ubuntu:22.04:LTSerlang1:24.2.1+dfsg-1ubuntu0.4UBUNTU-CVE-2025-32433
Ubuntu:24.04:LTSerlang1:25.3.2.8+dfsg-1ubuntu4.3UBUNTU-CVE-2025-32433
Ubuntu:24.04:LTSerlang1:25.3.2.8+dfsg-1ubuntu4.3USN-7443-1

Affected products (as reported)

VendorProductVersions
erlang otp >= OTP-27.0-rc1, < OTP-27.3.3>= OTP-26.0-rc1, < OTP-26.2.5.11< OTP-25.3.2.20

Weakness: CWE-306 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

References