Actively exploited · Published Apr 25, 2025 · Assigned by GitHub_M

CVE-2025-32432Craft CMS Allows Remote Code Execution

Critical 10.0 Exploited

In plain English

A critical-severity code injection in cms from craftcms. Attackers are actively exploiting it in the wild (listed by CISA on March 20, 2026). The chance it is exploited in the next 30 days is estimated at 99.8% (higher than 99.9% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)99.8%top 0.0% of all CVEs
Exploited in the wildYesCISA KEV since Mar 20, 2026
Attack tooling3Metasploit, Nuclei, Public PoC

CISA guidance

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Federal agencies must remediate by Apr 3, 2026.

Official description

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcraftcms/cms3.9.15GHSA-f3gw-9ww9-jmc3
Packagistcraftcms/cms4.14.15GHSA-f3gw-9ww9-jmc3
Packagistcraftcms/cms5.6.17GHSA-f3gw-9ww9-jmc3

Affected products (as reported)

VendorProductVersions
craftcms cms >= 3.0.0-RC1, < 3.9.15>= 4.0.0-RC1, < 4.14.15>= 5.0.0-RC1, < 5.6.17

Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L

References