Vulnerability · Published Jul 7, 2025 · Assigned by GitHub_M

CVE-2025-32023Redis allows out of bounds writes in hyperloglog commands leading to RCE

High 7.0

In plain English

A high-severity security flaw in redis from redis. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 6.5% (higher than 94% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.0High
Exploit odds (30 days)6.5%top 6.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Redis is an open source, in-memory database that persists on disk. From 2.8 to before 8.0.3, 7.4.5, 7.2.10, and 6.2.19, an authenticated user may use a specially crafted string to trigger a stack/heap out of bounds write on hyperloglog operations, potentially leading to remote code execution. The bug likely affects all Redis versions with hyperloglog operations implemented. This vulnerability is fixed in 8.0.3, 7.4.5, 7.2.10, and 6.2.19. An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing hyperloglog operations. This can be done using ACL to restrict HLL commands.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8redis6.2.19-1.module_el8.10.0+4030+0c7fcc00ALSA-2025:12006
AlmaLinux:9redis7.2.10-1.module_el9.6.0+173+efaf9205ALSA-2025:12008
AlmaLinux:8redis-devel6.2.19-1.module_el8.10.0+4030+0c7fcc00ALSA-2025:12006
AlmaLinux:9redis-devel7.2.10-1.module_el9.6.0+173+efaf9205ALSA-2025:12008
AlmaLinux:8redis-doc6.2.19-1.module_el8.10.0+4030+0c7fcc00ALSA-2025:12006
AlmaLinux:9redis-doc7.2.10-1.module_el9.6.0+173+efaf9205ALSA-2025:12008
AlmaLinux:10valkey8.0.4-1.el10_0ALSA-2025:11401
AlmaLinux:10valkey-devel8.0.4-1.el10_0ALSA-2025:11401
Alpine:v3.22redict7.3.3-r2ALPINE-CVE-2025-32023
Alpine:v3.23redict7.3.3-r2ALPINE-CVE-2025-32023
Alpine:v3.24redict7.3.3-r2ALPINE-CVE-2025-32023
Alpine:v3.21redis7.2.11-r0ALPINE-CVE-2025-32023
Alpine:v3.22redis8.0.3-r0ALPINE-CVE-2025-32023
Alpine:v3.23redis8.0.3-r0ALPINE-CVE-2025-32023
Alpine:v3.24redis8.0.3-r0ALPINE-CVE-2025-32023
Alpine:v3.20valkey7.2.11-r0ALPINE-CVE-2025-32023
Alpine:v3.21valkey7.2.11-r0ALPINE-CVE-2025-32023
Alpine:v3.22valkey8.1.1-r2ALPINE-CVE-2025-32023
Alpine:v3.23valkey8.1.1-r2ALPINE-CVE-2025-32023
Alpine:v3.24valkey8.1.1-r2ALPINE-CVE-2025-32023
Debian:14redict7.3.5+ds-1DEBIAN-CVE-2025-32023
Debian:12redis5:7.0.15-1~deb12u5DSA-5969-1
Debian:12redis5:7.0.15-1~deb12u5DEBIAN-CVE-2025-32023
Debian:13redis5:8.0.2-2DEBIAN-CVE-2025-32023
Debian:14redis5:8.0.2-2DEBIAN-CVE-2025-32023
Debian:13valkey8.1.1+dfsg1-3DEBIAN-CVE-2025-32023
Debian:14valkey8.1.1+dfsg1-3DEBIAN-CVE-2025-32023
Rocky Linux:8redis0:6.2.19-1.module+el8.10.0+2013+383ef3e1RLSA-2025:12006
Rocky Linux:9redis0:6.2.19-1.el9_6RLSA-2025:11453
Rocky Linux:9redis0:7.2.10-1.module+el9.6.0+32323+e27e860aRLSA-2025:12008
Rocky Linux:10valkey0:8.0.4-1.el10_0RLSA-2025:11401
Ubuntu:25.10redictno fix listedUBUNTU-CVE-2025-32023
Ubuntu:26.04:LTSredictno fix listedUBUNTU-CVE-2025-32023
Ubuntu:26.10redictno fix listedUBUNTU-CVE-2025-32023
Ubuntu:24.04:LTSredis5:7.0.15-1ubuntu0.24.04.3USN-8120-1
Ubuntu:24.04:LTSredis5:7.0.15-1ubuntu0.24.04.3UBUNTU-CVE-2025-32023
Ubuntu:25.10redisno fix listedUBUNTU-CVE-2025-32023
Ubuntu:26.04:LTSredisno fix listedUBUNTU-CVE-2025-32023
Ubuntu:26.10redisno fix listedUBUNTU-CVE-2025-32023
Ubuntu:24.04:LTSvalkey7.2.11+dfsg1-0ubuntu0.2UBUNTU-CVE-2025-32023

Affected products (as reported)

VendorProductVersions
redis redis >= 8.0.0, < 8.0.3>= 7.4-rc1, < 7.4.5>= 7.0.0, < 7.2.10>= 2.8.0, < 6.2.19

Weakness: CWE-680 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

References