Vulnerability · Published Jul 23, 2025 · Assigned by GitHub_M
CVE-2025-32019Harbor's repository description page allows for XSS
Medium 4.1
In plain English
A medium-severity cross-site scripting in harbor from goharbor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Harbor is an open source trusted cloud native registry project that stores, signs, and scans content. Versions 2.11.2 and below, as well as versions 2.12.0-rc1 and 2.13.0-rc1, contain a vulnerability where the markdown field in the info tab page can be exploited to inject XSS code. This is fixed in versions 2.11.3 and 2.12.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/goharbor/harbor | 2.12.4-rc1 | GHSA-f9vc-vf3r-pqqq |
| Go | github.com/goharbor/harbor | 2.13.1-rc1 | GHSA-f9vc-vf3r-pqqq |
| Go | github.com/goharbor/harbor | no fix listed | GHSA-f9vc-vf3r-pqqq |
| Go | github.com/goharbor/harbor | 2.4.0-rc1.0.20250421072404-a13a16383a41 | GHSA-f9vc-vf3r-pqqq |
| Go | github.com/goharbor/harbor | no fix listed | GO-2025-3825 |
| Go | github.com/goharbor/harbor | no fix listed | GO-2025-3825 |
| Go | github.com/goharbor/harbor | 2.12.4-rc1+incompatible | GO-2025-3825 |
| Go | github.com/goharbor/harbor | 2.13.1-rc1+incompatible | GO-2025-3825 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N
References
- https://github.com/goharbor/harbor/security/advisories/GHSA-f9vc-vf3r-pqqq x_refsource_CONFIRM
- https://github.com/goharbor/harbor/commit/76c2c5f7cfd9edb356cbb373889a59cc3217a058 x_refsource_MISC
- https://github.com/goharbor/harbor/commit/a13a16383a41a8e20f524593cb290dc52f86f088 x_refsource_MISC
- https://github.com/goharbor/harbor/commit/f019430872118852f83f96cac9c587b89052d1e5 x_refsource_MISC