Vulnerability · Published Apr 6, 2025 · Assigned by GitHub_M

CVE-2025-31492mod_auth_openidc allows OIDCProviderAuthRequestMethod POSTs to leak protected data

High 8.2

In plain English

A high-severity information exposure in mod_auth_openidc from OpenIDC. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.6%top 51.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

mod_auth_openidc is an OpenID Certified authentication and authorization module for the Apache 2.x HTTP server that implements the OpenID Connect Relying Party functionality. Prior to 2.4.16.11, a bug in a mod_auth_openidc results in disclosure of protected content to unauthenticated users. The conditions for disclosure are an OIDCProviderAuthRequestMethod POST, a valid account, and there mustn't be any application-level gateway (or load balancer etc) protecting the server. When you request a protected resource, the response includes the HTTP status, the HTTP headers, the intended response (the self-submitting form), and the protected resource (with no headers). This is an example of a request for a protected resource, including all the data returned. In the case where mod_auth_openidc returns a form, it has to return OK from check_userid so as not to go down the error path in httpd. This means httpd will try to issue the protected resource. oidc_content_handler is called early, which has the opportunity to prevent the normal output being issued by httpd. oidc_content_handler has a number of checks for when it intervenes, but it doesn't check for this case, so the handler returns DECLINED. Consequently, httpd appends the protected content to the response. The issue has been patched in mod_auth_openidc versions >= 2.4.16.11.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8cjose0.6.1-4.module_el8.10.0+3881+234adf82ALSA-2025:3997
AlmaLinux:8cjose0.6.1-4.module_el8.9.0+3631+0ced13d7ALSA-2025:3997
AlmaLinux:8cjose-devel0.6.1-4.module_el8.10.0+3881+234adf82ALSA-2025:3997
AlmaLinux:8cjose-devel0.6.1-4.module_el8.9.0+3631+0ced13d7ALSA-2025:3997
AlmaLinux:10mod_auth_openidc2.4.15-4.el10_0.1ALSA-2025:7490
AlmaLinux:8mod_auth_openidc2.4.9.4-7.module_el8.10.0+3978+e883c40dALSA-2025:3997
AlmaLinux:9mod_auth_openidc2.4.10-1.el9_6.1ALSA-2025:7419
Debian:12libapache2-mod-auth-openidc2.4.12.3-2+deb12u3DEBIAN-CVE-2025-31492
Debian:12libapache2-mod-auth-openidc2.4.12.3-2+deb12u3DSA-5904-1
Debian:13libapache2-mod-auth-openidc2.4.16.11-1DEBIAN-CVE-2025-31492
Debian:14libapache2-mod-auth-openidc2.4.16.11-1DEBIAN-CVE-2025-31492
Rocky Linux:8cjose0:0.6.1-4.module+el8.9.0+1384+4b58c166RLSA-2025:3997
Rocky Linux:10mod_auth_openidc0:2.4.15-4.el10_0.1RLSA-2025:7490
Rocky Linux:8mod_auth_openidc0:2.4.9.4-7.module+el8.10.0+1953+b76d6417RLSA-2025:3997
Rocky Linux:9mod_auth_openidc0:2.4.10-1.el9_6.1RLSA-2025:7419
Ubuntu:22.04:LTSlibapache2-mod-auth-openidc2.4.11-1ubuntu0.1USN-7446-1
Ubuntu:22.04:LTSlibapache2-mod-auth-openidc2.4.11-1ubuntu0.1UBUNTU-CVE-2025-31492
Ubuntu:24.04:LTSlibapache2-mod-auth-openidc2.4.15.1-1ubuntu0.1USN-7446-1
Ubuntu:24.04:LTSlibapache2-mod-auth-openidc2.4.15.1-1ubuntu0.1UBUNTU-CVE-2025-31492
Ubuntu:25.10libapache2-mod-auth-openidcno fix listedUBUNTU-CVE-2025-31492

Affected products (as reported)

VendorProductVersions
OpenIDC mod_auth_openidc < 2.4.16.11

Weakness: CWE-200 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References