Vulnerability · Published Apr 3, 2025 · Assigned by GitHub_M

CVE-2025-31483Stored XSS in Miniflux Media Proxy due to improper Content-Security-Policy configuration

Medium 4.8

In plain English

A medium-severity cross-site scripting in v2 from miniflux. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)4.8Medium
Exploit odds (30 days)0.4%top 63.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Miniflux is a feed reader. Due to a weak Content Security Policy on the /proxy/* route, an attacker can bypass the CSP of the media proxy and execute cross-site scripting when opening external images in a new tab/window. To mitigate the vulnerability, the CSP for the media proxy has been changed from default-src 'self' to default-src 'none'; form-action 'none'; sandbox;. This vulnerability is fixed in 2.2.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13minifluxno fix listedDEBIAN-CVE-2025-31483
Debian:14miniflux2.2.12-1DEBIAN-CVE-2025-31483
Gominiflux.appno fix listedGO-2025-3591
Gominiflux.app/v22.2.7GO-2025-3591
Gominiflux.app/v22.2.7GHSA-cq88-842x-2jhp
Ubuntu:25.10minifluxno fix listedUBUNTU-CVE-2025-31483
Ubuntu:26.10minifluxno fix listedUBUNTU-CVE-2025-31483

Affected products (as reported)

VendorProductVersions
miniflux v2 < 2.2.7

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N

References