Vulnerability · Published Mar 31, 2025 · Assigned by GitHub_M

CVE-2025-31129jooby-pac4j: deserialization of untrusted data

High 8.8

In plain English

A high-severity unsafe deserialization in jooby from jooby-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.7%top 48.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Jooby is a web framework for Java and Kotlin. The pac4j io.jooby.internal.pac4j.SessionStoreImpl#get module deserializes untrusted data. This vulnerability is fixed in 2.17.0 (2.x) and 3.7.0 (3.x).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenio.jooby:jooby-pac4j2.17.0GHSA-7c5v-895v-w4q5
Mavenio.jooby:jooby-pac4j3.7.0GHSA-7c5v-895v-w4q5

Affected products (as reported)

VendorProductVersions
jooby-project jooby >= 3.0.0.M1, < 3.7.0< 2.17.0

Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References