Vulnerability · Published Apr 1, 2025 · Assigned by GitHub_M

CVE-2025-31121OpenEMR allows XSS in Patient Image feature

High 7.0

In plain English

A high-severity cross-site scripting in openemr from openemr. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 17.3% (higher than 97% of all known vulnerabilities).

Severity (CVSS 4.0)7.0High
Exploit odds (30 days)17.3%top 2.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

OpenEMR is a free and open source electronic health records and medical practice management application. Prior to 7.0.3.1, the Patient Image feature in OpenEMR is vulnerable to cross-site scripting attacks via the EXIF title in an image. This vulnerability is fixed in 7.0.3.1.

Affected products (as reported)

VendorProductVersions
openemr openemr < 7.0.3.1

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References