Vulnerability · Published Apr 9, 2025 · Assigned by apache

CVE-2025-30677Apache Pulsar IO Kafka Connector, Apache Pulsar IO Kafka Connect Adaptor: Sensitive information logged in Pulsar's Apache Kafka Connectors

Medium 6.3

In plain English

A medium-severity sensitive data in logs in Apache Pulsar IO Kafka Connect Adaptor from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.3Medium
Exploit odds (30 days)0.7%top 45.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Apache Pulsar contains multiple connectors for integrating with Apache Kafka. The Pulsar IO Apache Kafka Source Connector, Sink Connector, and Kafka Connect Adaptor Sink Connector log sensitive configuration properties in plain text in application logs. This vulnerability can lead to unintended exposure of credentials in log files, potentially allowing attackers with access to these logs to obtain Apache Kafka credentials. The vulnerability's impact is limited by the fact that an attacker would need access to the application logs to exploit this issue. This issue affects Apache Pulsar IO's Apache Kafka connectors in all versions before 3.0.11, 3.3.6, and 4.0.4. 3.0.x version users should upgrade to at least 3.0.11. 3.3.x version users should upgrade to at least 3.3.6. 4.0.x version users should upgrade to at least 4.0.4. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.pulsar:pulsar-io-kafka3.0.11GHSA-rcqj-3fmp-5cqx
Mavenorg.apache.pulsar:pulsar-io-kafka3.3.6GHSA-rcqj-3fmp-5cqx
Mavenorg.apache.pulsar:pulsar-io-kafka4.0.4GHSA-rcqj-3fmp-5cqx
Mavenorg.apache.pulsar:pulsar-io-kafka-connect-adaptor3.0.11GHSA-rcqj-3fmp-5cqx
Mavenorg.apache.pulsar:pulsar-io-kafka-connect-adaptor3.3.6GHSA-rcqj-3fmp-5cqx
Mavenorg.apache.pulsar:pulsar-io-kafka-connect-adaptor4.0.4GHSA-rcqj-3fmp-5cqx

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Pulsar IO Kafka Connector 2.3.0 – before 3.0.113.1.0 – before 3.3.64.0.0 – before 4.0.4
Apache Software Foundation Apache Pulsar IO Kafka Connect Adaptor 2.3.0 – before 3.0.113.1.0 – before 3.3.64.0.0 – before 4.0.4

Weakness: CWE-532 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N

References