Vulnerability · Published Mar 27, 2025 · Assigned by GitHub_M
CVE-2025-30355Synapse vulnerable to federation denial of service via malformed events
High 7.1
In plain English
A high-severity improper input validation in synapse from element-hq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Synapse is an open source Matrix homeserver implementation. A malicious server can craft events which, when received, prevent Synapse version up to 1.127.0 from federating with other servers. The vulnerability has been exploited in the wild and has been fixed in Synapse v1.127.1. No known workarounds are available.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.21 | synapse | 1.127.1-r0 | ALPINE-CVE-2025-30355 |
| Alpine:v3.22 | synapse | 1.127.1-r0 | ALPINE-CVE-2025-30355 |
| Alpine:v3.23 | synapse | 1.127.1-r0 | ALPINE-CVE-2025-30355 |
| Alpine:v3.24 | synapse | 1.127.1-r0 | ALPINE-CVE-2025-30355 |
| Debian:14 | matrix-synapse | 1.121.0-6 | DEBIAN-CVE-2025-30355 |
| PyPI | matrix-synapse | 1.127.1 | GHSA-v56r-hwv5-mxg6 |
| PyPI | matrix-synapse | 1.127.1 | PYSEC-2026-1614 |
| Ubuntu:24.04:LTS | matrix-synapse | no fix listed | UBUNTU-CVE-2025-30355 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| element-hq | synapse | < 1.127.1 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H