Vulnerability · Published May 13, 2025 · Assigned by GitHub_M

CVE-2025-30207Kirby vulnerable to path traversal in the router for PHP's built-in server

Low 2.3

In plain English

A low-severity path traversal in kirby from getkirby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.3Low
Exploit odds (30 days)0.6%top 51.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby setups that use PHP's built-in server. Such setups are commonly only used during local development. Sites that use other server software (such as Apache, nginx or Caddy) are not affected. A missing path traversal check allowed attackers to navigate all files on the server that were accessible to the PHP process, including files outside of the Kirby installation. The vulnerable implementation delegated all existing files to PHP, including existing files outside of the document root. This leads to a different response that allows attackers to determine whether the requested file exists. Because Kirby's router only delegates such requests to PHP and does not load or execute them, contents of the files were not exposed as PHP treats requests to files outside of the document root as invalid. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, the maintainers of Kirby have updated the router to check if existing static files are within the document root. Requests to files outside the document root are treated as page requests of the error page and will no longer allow to determine whether the file exists or not.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistgetkirby/cms3.9.8.3GHSA-9p3p-w5jf-8xxg
Packagistgetkirby/cms3.10.1.2GHSA-9p3p-w5jf-8xxg
Packagistgetkirby/cms4.7.1GHSA-9p3p-w5jf-8xxg

Affected products (as reported)

VendorProductVersions
getkirby kirby < 3.9.8.3>= 3.10.0, < 3.10.1.2>= 4.0.0, < 4.7.1

Weakness: CWE-22, CWE-23 · Vector: CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N

References