Vulnerability · Published Jun 3, 2025 · Assigned by GitHub_M

CVE-2025-30167Jupyter Core on Windows Has Uncontrolled Search Path Element Local Privilege Escalation Vulnerability

High 7.3

In plain English

A high-severity uncontrolled search path in jupyter_core from jupyter. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.2%top 90.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Jupyter Core is a package for the core common functionality of Jupyter projects. When using Jupyter Core prior to version 5.8.0 on Windows, the shared `%PROGRAMDATA%` directory is searched for configuration files (`SYSTEM_CONFIG_PATH` and `SYSTEM_JUPYTER_PATH`), which may allow users to create configuration files affecting other users. Only shared Windows systems with multiple users and unprotected `%PROGRAMDATA%` are affected. Users should upgrade to Jupyter Core version 5.8.0 or later to receive a patch. Some other mitigations are available. As administrator, modify the permissions on the `%PROGRAMDATA%` directory so it is not writable by unauthorized users; or as administrator, create the `%PROGRAMDATA%\jupyter` directory with appropriately restrictive permissions; or as user or administrator, set the `%PROGRAMDATA%` environment variable to a directory with appropriately restrictive permissions (e.g. controlled by administrators _or_ the current user).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIjupyter-core5.8.1GHSA-33p9-3p43-82vq
PyPIjupyter-core5.8.1PYSEC-2026-1477
Ubuntu:24.04:LTSjupyter-coreno fix listedUBUNTU-CVE-2025-30167
Ubuntu:25.10jupyter-coreno fix listedUBUNTU-CVE-2025-30167
Ubuntu:26.04:LTSjupyter-coreno fix listedUBUNTU-CVE-2025-30167
Ubuntu:26.10jupyter-coreno fix listedUBUNTU-CVE-2025-30167

Affected products (as reported)

VendorProductVersions
jupyter jupyter_core < 5.8.0

Weakness: CWE-427 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

References