Vulnerability · Published Mar 19, 2025 · Assigned by GitHub_M

CVE-2025-30152Sylius PayPal Plugin has an Order Manipulation Vulnerability after PayPal Checkout

Medium 6.5

In plain English

A medium-severity security flaw in PayPalPlugin from Sylius. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.4%top 71.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The Syliud PayPal Plugin is the Sylius Core Team’s plugin for the PayPal Commerce Platform. Prior to 1.6.2, 1.7.2, and 2.0.2, a discovered vulnerability allows users to modify their shopping cart after completing the PayPal Checkout process and payment authorization. If a user initiates a PayPal transaction from a product page or the cart page and then returns to the order summary page, they can still manipulate the cart contents before finalizing the order. As a result, the order amount in Sylius may be higher than the amount actually captured by PayPal, leading to a scenario where merchants deliver products or services without full payment. The issue is fixed in versions: 1.6.2, 1.7.2, 2.0.2 and above.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistsylius/paypal-plugin1.6.2GHSA-hxg4-65p5-9w37
Packagistsylius/paypal-plugin1.7.2GHSA-hxg4-65p5-9w37
Packagistsylius/paypal-plugin2.0.2GHSA-hxg4-65p5-9w37

Affected products (as reported)

VendorProductVersions
Sylius PayPalPlugin < 1.6.2>= 1.7.0, < 1.7.2>= 2.0.0, < 2.0.2

Weakness: CWE-472 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

References