Vulnerability · Published Apr 10, 2025 · Assigned by GitHub_M

CVE-2025-30148Silverstripe Framework has a XSS vulnerability in HTML editor

Medium 5.4

In plain English

A medium-severity cross-site scripting in silverstripe-framework from silverstripe. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.3%top 77.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Silverstripe Framework is a PHP framework which powers the Silverstripe CMS. Prior to 5.3.23, bad actor with access to edit content in the CMS could send a specifically crafted encoded payload to the server, which could be used to inject a JavaScript payload on the front end of the site. The payload would be sanitized on the client-side, but server-side sanitization doesn't catch it. The server-side sanitization logic has been updated to sanitize against this attack. This vulnerability is fixed in 5.3.23.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistsilverstripe/framework5.3.23GHSA-rhx4-hvx9-j387

Affected products (as reported)

VendorProductVersions
silverstripe silverstripe-framework < 5.3.23

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

References