Vulnerability · Published Mar 19, 2025 · Assigned by GitHub_M

CVE-2025-29783vLLM Allows Remote Code Execution via Mooncake Integration

Critical 9.1

In plain English

A critical-severity unsafe deserialization in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.7%top 45.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. When vLLM is configured to use Mooncake, unsafe deserialization exposed directly over ZMQ/TCP on all network interfaces will allow attackers to execute remote code on distributed hosts. This is a remote code execution vulnerability impacting any deployments using Mooncake to distribute KV across distributed hosts. This vulnerability is fixed in 0.8.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.8.0GHSA-x3m8-f7g5-qhm7
PyPIvllm0.8.0PYSEC-2025-63

Affected products (as reported)

VendorProductVersions
vllm-project vllm >= 0.6.5, < 0.8.0

Weakness: CWE-502 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

References