Vulnerability · Published Mar 3, 2025 · Assigned by GitHub_M

CVE-2025-27423Improper Input Validation in Vim

High 7.1

In plain English

A high-severity command injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 22.5% (higher than 98% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)22.5%top 2.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vim is an open source, command line text editor. Vim is distributed with the tar.vim plugin, that allows easy editing and viewing of (compressed or uncompressed) tar files. Starting with 9.1.0858, the tar.vim plugin uses the ":read" ex command line to append below the cursor position, however the is not sanitized and is taken literally from the tar archive. This allows to execute shell commands via special crafted tar archives. Whether this really happens, depends on the shell being used ('shell' option, which is set using $SHELL). The issue has been fixed as of Vim patch v9.1.1164

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.22vim9.1.1164-r0ALPINE-CVE-2025-27423
Alpine:v3.23vim9.1.1164-r0ALPINE-CVE-2025-27423
Alpine:v3.24vim9.1.1164-r0ALPINE-CVE-2025-27423
Debian:13vim2:9.1.1230-1DEBIAN-CVE-2025-27423
Debian:14vim2:9.1.1230-1DEBIAN-CVE-2025-27423

Affected products (as reported)

VendorProductVersions
vim vim < 9.1.1164

Weakness: CWE-77 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

References