Vulnerability · Published Mar 10, 2025 · Assigned by apache

CVE-2025-26865Apache OFBiz: Server-Side Template Injection affecting the ecommerce plugin leading to possible RCE

Low 3.5

In plain English

A low-severity security flaw in Apache OFBiz from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code.

Severity (CVSS 3.1)3.5Low
Exploit odds (30 days)0.7%top 48.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Apache OFBiz. This issue affects Apache OFBiz: from 18.12.17 before 18.12.18.   It's a regression between 18.12.17 and 18.12.18. In case you use something like that, which is not recommended! For security, only official releases should be used. In other words, if you use 18.12.17 you are still safe. The version 18.12.17 is not a affected. But something between 18.12.17 and 18.12.18 is. In that case, users are recommended to upgrade to version 18.12.18, which fixes the issue.

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache OFBiz 18.12.17 – before 18.12.18

Weakness: CWE-1336 · Vector: CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

References