Vulnerability · Published Feb 20, 2025 · Assigned by GitHub_M

CVE-2025-25299Cross-site scripting (XSS) in the real-time collaboration package

Low 2.3

In plain English

A low-severity cross-site scripting in ckeditor5 from ckeditor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.3Low
Exploit odds (30 days)0.6%top 50.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. During a recent internal audit, a Cross-Site Scripting (XSS) vulnerability was discovered in the CKEditor 5 real-time collaboration package. This vulnerability affects user markers, which represent users' positions within the document. It can lead to unauthorized JavaScript code execution, which might happen with a very specific editor and token endpoint configuration. This vulnerability affects only installations with Real-time collaborative editing enabled. The problem has been recognized and patched. The fix is available in version 44.2.1 (and above). Users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:25.10ckeditorno fix listedUBUNTU-CVE-2025-25299
Ubuntu:22.04:LTSckeditor3no fix listedUBUNTU-CVE-2025-25299
Ubuntu:24.04:LTSckeditor3no fix listedUBUNTU-CVE-2025-25299
Ubuntu:22.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2025-25299
Ubuntu:24.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2025-25299
Ubuntu:25.10ldap-account-managerno fix listedUBUNTU-CVE-2025-25299
Ubuntu:26.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2025-25299
Ubuntu:22.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2025-25299
Ubuntu:24.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2025-25299
Ubuntu:25.10request-tracker4no fix listedUBUNTU-CVE-2025-25299
Ubuntu:26.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2025-25299
npm@ckeditor/ckeditor5-real-time-collaboration44.2.1GHSA-j3mm-wmfm-mwvh
npmckeditor5-premium-features44.2.1GHSA-j3mm-wmfm-mwvh

Affected products (as reported)

VendorProductVersions
ckeditor ckeditor5 @ckeditor/ckeditor5-real-time-collaboration: >= 41.3.0, < 44.2.1ckeditor5-premium-features: >= 42.0.0, < 44.2.1

Weakness: CWE-79, CWE-80 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

References