Vulnerability · Published Aug 15, 2025 · Assigned by GitHub_M
CVE-2025-24975Firebird Non-Authorized Access to Encrypted Database Using Execute Statement on External
High 7.1
In plain English
A high-severity security flaw in firebird from FirebirdSQL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Firebird is a relational database. Prior to snapshot versions 4.0.6.3183, 5.0.2.1610, and 6.0.0.609, Firebird is vulnerable if ExtConnPoolSize is not set equal to 0. If connections stored in ExtConnPool are not verified for presence and suitability of the CryptCallback interface is used when created versus what is available could result in a segfault in the server process. Encrypted databases, accessed by execute statement on external, may be accessed later by an attachment missing a key to that database. In a case when execute statement are chained, segfault may happen. Additionally, the segfault may affect unencrypted databases. This issue has been patched in snapshot versions 4.0.6.3183, 5.0.2.1610, and 6.0.0.609 and point releases 4.0.6 and 5.0.2. A workaround for this issue involves setting ExtConnPoolSize equal to 0 in firebird.conf.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | firebird4.0 | 4.0.5.3140.ds6-17+deb13u1 | DEBIAN-CVE-2025-24975 |
| Debian:13 | firebird4.0 | 4.0.5.3140.ds6-17+deb13u1 | DSA-5992-1 |
| Debian:14 | firebird4.0 | 4.0.6.3221.ds6-1 | DEBIAN-CVE-2025-24975 |
| Ubuntu:25.10 | firebird3.0 | no fix listed | UBUNTU-CVE-2025-24975 |
| Ubuntu:26.04:LTS | firebird3.0 | no fix listed | UBUNTU-CVE-2025-24975 |
| Ubuntu:26.10 | firebird3.0 | no fix listed | UBUNTU-CVE-2025-24975 |
| Ubuntu:25.10 | firebird4.0 | no fix listed | UBUNTU-CVE-2025-24975 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| FirebirdSQL | firebird | < 6.0.0.609< 5.0.2.1610< 4.0.6.3183 |
Weakness: CWE-754 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
References
- https://github.com/FirebirdSQL/firebird/security/advisories/GHSA-fx9r-rj68-7p69 x_refsource_CONFIRM
- https://github.com/FirebirdSQL/firebird/issues/8429 x_refsource_MISC
- https://github.com/FirebirdSQL/firebird/commit/658abd20449f72097fbbce57e8e6ae42ff837fb6 x_refsource_MISC
- https://www.vicarius.io/vsociety/posts/cve-2025-24975-detect-vulnerable-firebird
- https://www.vicarius.io/vsociety/posts/cve-2025-24975-mitigate-firebird-vulnerability