Vulnerability · Published Feb 3, 2025 · Assigned by GitHub_M

CVE-2025-24959Environment Variable Injection for dotenv API in zx

Low 1.0

In plain English

A low-severity code injection in zx from google. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)1.0Low
Exploit odds (30 days)0.2%top 93.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

zx is a tool for writing better scripts. An attacker with control over environment variable values can inject unintended environment variables into `process.env`. This can lead to arbitrary command execution or unexpected behavior in applications that rely on environment variables for security-sensitive operations. Applications that process untrusted input and pass it through `dotenv.stringify` are particularly vulnerable. This issue has been patched in version 8.3.2. Users should immediately upgrade to this version to mitigate the vulnerability. If upgrading is not feasible, users can mitigate the vulnerability by sanitizing user-controlled environment variable values before passing them to `dotenv.stringify`. Specifically, avoid using `"`, `'`, and backticks in values, or enforce strict validation of environment variables before usage.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:24.04:LTSnode-zxno fix listedUBUNTU-CVE-2025-24959
Ubuntu:25.10node-zxno fix listedUBUNTU-CVE-2025-24959
Ubuntu:26.04:LTSnode-zxno fix listedUBUNTU-CVE-2025-24959
Ubuntu:26.10node-zxno fix listedUBUNTU-CVE-2025-24959
npmzx8.3.2GHSA-qwp8-x4ff-5h87

Affected products (as reported)

VendorProductVersions
google zx >= 8.3.0, < 8.3.2

Weakness: CWE-94 · Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

References