Vulnerability · Published Mar 18, 2025 · Assigned by GitHub_M

CVE-2025-24801GLPI allows authenticated remote code execution

High 8.6

In plain English

A high-severity unrestricted file upload in glpi from glpi-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 21.1% (higher than 98% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)21.1%top 2.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

GLPI is a free asset and IT management software package. An authenticated user can upload and force the execution of *.php files located on the GLPI server. This vulnerability is fixed in 10.0.18.

Affected products (as reported)

VendorProductVersions
glpi-project glpi >= 0.85, < 10.0.18

Weakness: CWE-434 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

References