Vulnerability · Published Jan 27, 2025 · Assigned by GitHub_M
CVE-2025-24367Cacti allows Arbitrary File Creation leading to RCE
High 8.7
In plain English
A high-severity security flaw in cacti from Cacti. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 58.8% (higher than 99.1% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Cacti is an open source performance and fault management framework. An authenticated Cacti user can abuse graph creation and graph template functionality to create arbitrary PHP scripts in the web root of the application, leading to remote code execution on the server. This vulnerability is fixed in 1.2.29.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.21 | cacti | 1.2.29-r0 | ALPINE-CVE-2025-24367 |
| Alpine:v3.22 | cacti | 1.2.29-r0 | ALPINE-CVE-2025-24367 |
| Alpine:v3.23 | cacti | 1.2.29-r0 | ALPINE-CVE-2025-24367 |
| Alpine:v3.24 | cacti | 1.2.29-r0 | ALPINE-CVE-2025-24367 |
| Debian:12 | cacti | 1.2.24+ds1-1+deb12u5 | DSA-5862-1 |
| Debian:12 | cacti | 1.2.24+ds1-1+deb12u5 | DEBIAN-CVE-2025-24367 |
| Debian:13 | cacti | 1.2.28+ds1-4 | DEBIAN-CVE-2025-24367 |
| Debian:14 | cacti | 1.2.28+ds1-4 | DEBIAN-CVE-2025-24367 |
| Ubuntu:24.04:LTS | cacti | no fix listed | UBUNTU-CVE-2025-24367 |
| Ubuntu:25.10 | cacti | no fix listed | UBUNTU-CVE-2025-24367 |
Affected products (as reported)
Weakness: CWE-144 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N