Actively exploited · Published Mar 11, 2025 · Assigned by apple
CVE-2025-24201
Critical 10.0 Exploited
In plain English
A critical-severity out-of-bounds write in iOS and iPadOS from Apple. Attackers are actively exploiting it in the wild (listed by CISA on March 13, 2025). The chance it is exploited in the next 30 days is estimated at 3.8% (higher than 90% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
CISA guidance
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Federal agencies must remediate by Apr 3, 2025.
Official description
An out-of-bounds write issue was addressed with improved checks to prevent unauthorized actions. This issue is fixed in Safari 18.3.1, iOS 15.8.4 and iPadOS 15.8.4, iOS 16.7.11 and iPadOS 16.7.11, iOS 18.3.2 and iPadOS 18.3.2, iPadOS 17.7.6, macOS Sequoia 15.3.2, visionOS 2.3.2, watchOS 11.4. Maliciously crafted web content may be able to break out of Web Content sandbox. This is a supplementary fix for an attack that was blocked in iOS 17.2. (Apple is aware of a report that this issue may have been exploited in an extremely sophisticated attack against specific targeted individuals on versions of iOS before iOS 17.2.).
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | webkit2gtk3 | 2.46.6-2.el8_10 | ALSA-2025:2863 |
| AlmaLinux:9 | webkit2gtk3 | 2.46.6-2.el9_5 | ALSA-2025:2864 |
| AlmaLinux:8 | webkit2gtk3-devel | 2.46.6-2.el8_10 | ALSA-2025:2863 |
| AlmaLinux:9 | webkit2gtk3-devel | 2.46.6-2.el9_5 | ALSA-2025:2864 |
| AlmaLinux:8 | webkit2gtk3-jsc | 2.46.6-2.el8_10 | ALSA-2025:2863 |
| AlmaLinux:9 | webkit2gtk3-jsc | 2.46.6-2.el9_5 | ALSA-2025:2864 |
| AlmaLinux:8 | webkit2gtk3-jsc-devel | 2.46.6-2.el8_10 | ALSA-2025:2863 |
| AlmaLinux:9 | webkit2gtk3-jsc-devel | 2.46.6-2.el9_5 | ALSA-2025:2864 |
| Alpine:v3.21 | qt5-qtwebengine | 5.15.17-r7 | ALPINE-CVE-2025-24201 |
| Alpine:v3.22 | qt5-qtwebengine | 5.15.17-r10 | ALPINE-CVE-2025-24201 |
| Alpine:v3.23 | qt5-qtwebengine | 5.15.17-r10 | ALPINE-CVE-2025-24201 |
| Alpine:v3.22 | qt6-qtwebengine | 6.8.2-r3 | ALPINE-CVE-2025-24201 |
| Alpine:v3.23 | qt6-qtwebengine | 6.8.2-r3 | ALPINE-CVE-2025-24201 |
| Alpine:v3.24 | qt6-qtwebengine | 6.8.2-r3 | ALPINE-CVE-2025-24201 |
| Debian:12 | chromium | 134.0.6998.88-1~deb12u1 | DSA-5877-1 |
| Debian:12 | chromium | 134.0.6998.88-1~deb12u1 | DEBIAN-CVE-2025-24201 |
| Debian:12 | webkit2gtk | 2.48.0-1~deb12u1 | DSA-5885-1 |
| Debian:12 | webkit2gtk | 2.48.0-1~deb12u1 | DEBIAN-CVE-2025-24201 |
| Debian:13 | webkit2gtk | 2.48.0-1 | DEBIAN-CVE-2025-24201 |
| Debian:14 | webkit2gtk | 2.48.0-1 | DEBIAN-CVE-2025-24201 |
| Debian:12 | wpewebkit | no fix listed | DEBIAN-CVE-2025-24201 |
| Debian:13 | wpewebkit | 2.48.0-1 | DEBIAN-CVE-2025-24201 |
| Debian:14 | wpewebkit | 2.48.0-1 | DEBIAN-CVE-2025-24201 |
| Rocky Linux:8 | webkit2gtk3 | 0:2.46.6-2.el8_10 | RLSA-2025:2863 |
| Ubuntu:22.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2025-24201 |
| Ubuntu:24.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2025-24201 |
| Ubuntu:22.04:LTS | webkit2gtk | 2.48.0-0ubuntu0.22.04.1 | USN-7395-1 |
| Ubuntu:22.04:LTS | webkit2gtk | 2.48.0-0ubuntu0.22.04.1 | UBUNTU-CVE-2025-24201 |
| Ubuntu:24.04:LTS | webkit2gtk | 2.48.0-0ubuntu0.24.04.1 | UBUNTU-CVE-2025-24201 |
| Ubuntu:24.04:LTS | webkit2gtk | 2.48.0-0ubuntu0.24.04.1 | USN-7395-1 |
| Ubuntu:22.04:LTS | wpewebkit | no fix listed | UBUNTU-CVE-2025-24201 |
Affected products (as reported)
Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
References
- https://support.apple.com/en-us/122281
- https://support.apple.com/en-us/122283
- https://support.apple.com/en-us/122284
- https://support.apple.com/en-us/122285
- https://support.apple.com/en-us/122345
- https://support.apple.com/en-us/122346
- https://support.apple.com/en-us/122372
- https://support.apple.com/en-us/122376
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-24201 government-resource
- http://seclists.org/fulldisclosure/2025/Mar/2
- http://seclists.org/fulldisclosure/2025/Mar/3
- http://seclists.org/fulldisclosure/2025/Mar/4
- http://seclists.org/fulldisclosure/2025/Mar/5
- http://seclists.org/fulldisclosure/2025/Apr/16
- http://seclists.org/fulldisclosure/2025/Oct/31
- http://seclists.org/fulldisclosure/2025/Oct/1
- https://lists.debian.org/debian-lts-announce/2025/06/msg00016.html
- http://seclists.org/fulldisclosure/2025/Jun/19
- http://seclists.org/fulldisclosure/2025/Apr/7
- https://github.com/JGoyd/Glass-Cage-iOS18-CVE-2025-24085-CVE-2025-24201
- https://github.com/cisagov/vulnrichment/issues/194