Vulnerability · Published Jan 27, 2025 · Assigned by apple

CVE-2025-24162

Medium 6.5

In plain English

A medium-severity out-of-bounds read in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)1.0%top 38.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

This issue was addressed through improved state management. This issue is fixed in Safari 18.3, iOS 18.3 and iPadOS 18.3, macOS Sequoia 15.3, tvOS 18.3, visionOS 2.3, watchOS 11.3. Processing maliciously crafted web content may lead to an unexpected process crash.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.46.6-1.el8_10ALSA-2025:2034
AlmaLinux:9webkit2gtk32.46.6-1.el9_5ALSA-2025:2035
AlmaLinux:8webkit2gtk3-devel2.46.6-1.el8_10ALSA-2025:2034
AlmaLinux:9webkit2gtk3-devel2.46.6-1.el9_5ALSA-2025:2035
AlmaLinux:8webkit2gtk3-jsc2.46.6-1.el8_10ALSA-2025:2034
AlmaLinux:9webkit2gtk3-jsc2.46.6-1.el9_5ALSA-2025:2035
AlmaLinux:8webkit2gtk3-jsc-devel2.46.6-1.el8_10ALSA-2025:2034
AlmaLinux:9webkit2gtk3-jsc-devel2.46.6-1.el9_5ALSA-2025:2035
Debian:12webkit2gtk2.46.6-1~deb12u1DEBIAN-CVE-2025-24162
Debian:12webkit2gtk2.46.6-1~deb12u1DSA-5865-1
Debian:13webkit2gtk2.46.6-1DEBIAN-CVE-2025-24162
Debian:14webkit2gtk2.46.6-1DEBIAN-CVE-2025-24162
Debian:12wpewebkitno fix listedDEBIAN-CVE-2025-24162
Debian:13wpewebkit2.46.6-1DEBIAN-CVE-2025-24162
Debian:14wpewebkit2.46.6-1DEBIAN-CVE-2025-24162
Rocky Linux:8webkit2gtk30:2.46.6-1.el8_10RLSA-2025:2034
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-24162
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-24162
Ubuntu:22.04:LTSwebkit2gtk2.46.6-0ubuntu0.22.04.1USN-7279-1
Ubuntu:22.04:LTSwebkit2gtk2.46.6-0ubuntu0.22.04.1UBUNTU-CVE-2025-24162
Ubuntu:24.04:LTSwebkit2gtk2.46.6-0ubuntu0.24.04.1UBUNTU-CVE-2025-24162
Ubuntu:24.04:LTSwebkit2gtk2.46.6-0ubuntu0.24.04.1USN-7279-1
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2025-24162

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 18.3
Apple iOS and iPadOS 0 – before 18.3
Apple macOS 0 – before 15.3
Apple tvOS 0 – before 18.3
Apple visionOS 0 – before 2.3
Apple watchOS 0 – before 11.3

Weakness: CWE-125 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

References