Vulnerability · Published Jan 27, 2025 · Assigned by apple

CVE-2025-24150

High 8.8

In plain English

A high-severity command injection in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.9% (higher than 87% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)2.9%top 12.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A privacy issue was addressed with improved handling of files. This issue is fixed in Safari 18.3, iOS 18.3 and iPadOS 18.3, macOS Sequoia 15.3. Copying a URL from Web Inspector may lead to command injection.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.46.6-1.el8_10ALSA-2025:2034
AlmaLinux:9webkit2gtk32.46.6-1.el9_5ALSA-2025:2035
AlmaLinux:8webkit2gtk3-devel2.46.6-1.el8_10ALSA-2025:2034
AlmaLinux:9webkit2gtk3-devel2.46.6-1.el9_5ALSA-2025:2035
AlmaLinux:8webkit2gtk3-jsc2.46.6-1.el8_10ALSA-2025:2034
AlmaLinux:9webkit2gtk3-jsc2.46.6-1.el9_5ALSA-2025:2035
AlmaLinux:8webkit2gtk3-jsc-devel2.46.6-1.el8_10ALSA-2025:2034
AlmaLinux:9webkit2gtk3-jsc-devel2.46.6-1.el9_5ALSA-2025:2035
Debian:12webkit2gtk2.46.6-1~deb12u1DEBIAN-CVE-2025-24150
Debian:12webkit2gtk2.46.6-1~deb12u1DSA-5865-1
Debian:13webkit2gtk2.46.6-1DEBIAN-CVE-2025-24150
Debian:14webkit2gtk2.46.6-1DEBIAN-CVE-2025-24150
Debian:12wpewebkitno fix listedDEBIAN-CVE-2025-24150
Debian:13wpewebkit2.46.6-1DEBIAN-CVE-2025-24150
Debian:14wpewebkit2.46.6-1DEBIAN-CVE-2025-24150
Rocky Linux:8webkit2gtk30:2.46.6-1.el8_10RLSA-2025:2034
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-24150
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-24150
Ubuntu:22.04:LTSwebkit2gtk2.46.6-0ubuntu0.22.04.1USN-7279-1
Ubuntu:22.04:LTSwebkit2gtk2.46.6-0ubuntu0.22.04.1UBUNTU-CVE-2025-24150
Ubuntu:24.04:LTSwebkit2gtk2.46.6-0ubuntu0.24.04.1UBUNTU-CVE-2025-24150
Ubuntu:24.04:LTSwebkit2gtk2.46.6-0ubuntu0.24.04.1USN-7279-1
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2025-24150

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 18.3
Apple iOS and iPadOS 0 – before 18.3
Apple macOS 0 – before 15.3

Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References