Vulnerability · Published Feb 4, 2025 · Assigned by apache

CVE-2025-23015Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions

High 8.8

In plain English

A high-severity security flaw in Apache Cassandra from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)1.0%top 36.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.cassandra:cassandra-all5.0.3GHSA-wmcc-9vch-jmx4
Mavenorg.apache.cassandra:cassandra-all4.1.8GHSA-wmcc-9vch-jmx4
Mavenorg.apache.cassandra:cassandra-all4.0.16GHSA-wmcc-9vch-jmx4
Mavenorg.apache.cassandra:cassandra-all3.11.18GHSA-wmcc-9vch-jmx4
Mavenorg.apache.cassandra:cassandra-all3.0.31GHSA-wmcc-9vch-jmx4

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Cassandra 3.0.0 – through 3.0.303.1.0 – through 3.11.174.0.0 – through 4.0.154.1.0 – through 4.1.75.0.0 – through 5.0.2

Weakness: CWE-267 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References