Vulnerability · Published Jan 27, 2025 · Assigned by GitHub_M

CVE-2025-22604Cacti has Authenticated RCE via multi-line SNMP responses

Critical 9.1

In plain English

A critical-severity OS command injection in cacti from Cacti. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 5.3% (higher than 93% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)5.3%top 7.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling1Public PoC

Official description

Cacti is an open source performance and fault management framework. Due to a flaw in multi-line SNMP result parser, authenticated users can inject malformed OIDs in the response. When processed by ss_net_snmp_disk_io() or ss_net_snmp_disk_bytes(), a part of each OID will be used as a key in an array that is used as part of a system command, causing a command execution vulnerability. This vulnerability is fixed in 1.2.29.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.21cacti1.2.29-r0ALPINE-CVE-2025-22604
Alpine:v3.22cacti1.2.29-r0ALPINE-CVE-2025-22604
Alpine:v3.23cacti1.2.29-r0ALPINE-CVE-2025-22604
Alpine:v3.24cacti1.2.29-r0ALPINE-CVE-2025-22604
Debian:12cacti1.2.24+ds1-1+deb12u5DSA-5862-1
Debian:12cacti1.2.24+ds1-1+deb12u5DEBIAN-CVE-2025-22604
Debian:13cacti1.2.28+ds1-4DEBIAN-CVE-2025-22604
Debian:14cacti1.2.28+ds1-4DEBIAN-CVE-2025-22604
Ubuntu:24.04:LTScactino fix listedUBUNTU-CVE-2025-22604
Ubuntu:25.10cactino fix listedUBUNTU-CVE-2025-22604

Affected products (as reported)

VendorProductVersions
Cacti cacti <= 1.2.8

Weakness: CWE-78 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

References