Vulnerability · Published Mar 11, 2025 · Assigned by VulDB

CVE-2025-2173libzvbi conv.c vbi_strndup_iconv_ucs2 uninitialized pointer

Medium 5.3

In plain English

A medium-severity security flaw in libzvbi. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.6%top 50.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A vulnerability was found in libzvbi up to 0.2.43. It has been classified as problematic. Affected is the function vbi_strndup_iconv_ucs2 of the file src/conv.c. The manipulation of the argument src_length leads to uninitialized pointer. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The patch is identified as 8def647eea27f7fd7ad33ff79c2d6d3e39948dce. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12zvbi0.2.41-1+deb12u1DEBIAN-CVE-2025-2173
Debian:13zvbi0.2.44-1DEBIAN-CVE-2025-2173
Debian:14zvbi0.2.44-1DEBIAN-CVE-2025-2173

Affected products (as reported)

VendorProductVersions
n/a libzvbi 0.2.00.2.10.2.20.2.30.2.40.2.50.2.60.2.7

Weakness: CWE-824, CWE-908 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

References