Vulnerability · Published Dec 22, 2025 · Assigned by WPScan
CVE-2025-15033WooCommerce - Subscriber/Customer+ Order Data Disclosure
Medium 6.5
In plain English
A medium-severity information exposure in WooCommerce from Automattic. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities).
Official description
A vulnerability in WooCommerce 8.1 to 10.4.2 can allow logged-in customers to access order data of guest customers on sites with a certain configuration. This has been fixed in WooCommerce 10.4.3, as well as all the previously affected versions through point releases, starting from 8.1, where it has been fixed in 8.1.3. It does not affect WooCommerce 8.0 or earlier.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Automattic | WooCommerce | 8.1.0 – before 8.1.38.2.0 – before 8.2.48.3.0 – before 8.3.38.4.0 – before 8.4.28.5.0 – before 8.5.48.6.0 – before 8.6.38.7.0 – before 8.7.28.8.0 – before 8.8.6 |
Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
References
- https://wpscan.com/vulnerability/f55fd7d3-7fbe-474f-9406-f47f8aee5e57/ exploit, vdb-entry, technical-description