Vulnerability · Published Jan 28, 2026 · Assigned by Wordfence
CVE-2025-14795Stop Spammers Classic <= 2026.1 - Cross-Site Request Forgery via Email Allowlist
Medium 4.3
In plain English
A medium-severity cross-site request forgery in Stop Spammers Classic from webguyio. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities).
Official description
The Stop Spammers Classic plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2026.1. This is due to missing nonce validation in the ss_addtoallowlist class. This makes it possible for unauthenticated attackers to add arbitrary email addresses to the spam allowlist via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The vulnerability was partially patched in version 2026.1.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| webguyio | Stop Spammers Classic | 0 – through 2026.1 |
Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5d6f38d7-a769-422d-ae3f-565cb1cc8a73?source=cve
- https://plugins.trac.wordpress.org/browser/stop-spammer-registrations-plugin/tags/2025.4/classes/ss_addtoallowlist.php#L21
- https://plugins.trac.wordpress.org/changeset/3436357/
- https://plugins.trac.wordpress.org/changeset/3440788/