Vulnerability · Published Dec 15, 2025 · Assigned by AMZN
CVE-2025-14503Overly Permissive Trust Policy in Harmonix on AWS EKS
High 7.2
In plain English
A high-severity security flaw in Harmonix on AWS from AWS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities).
Official description
An overly-permissive IAM trust policy in the Harmonix on AWS framework may allow IAM principals in the same AWS account to escalate privileges via role assumption. The sample code for the EKS environment provisioning role is configured to trust the account root principal, which may enable any IAM principal in the same AWS account with sts:AssumeRole permissions to assume the role with administrative privileges. We recommend customers upgrade to Harmonix on AWS v0.4.2 or later if you have deployed the framework using versions v0.3.0 through v0.4.1.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| AWS | Harmonix on AWS | 0.3.0 – before 0.4.2 |
Weakness: CWE-266 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H