Vulnerability · Published Dec 9, 2025 · Assigned by GoogleCloud
CVE-2025-13428RCE in SecOps SOAR server via user-provided Python packages
High 8.6
In plain English
A high-severity improper input validation in Google Cloud SecOps SOAR from Google Cloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities).
Official description
A vulnerability exists in the SecOps SOAR server. The custom integrations feature allowed an authenticated user with an "IDE role" to achieve Remote Code Execution (RCE) in the server. The flaw stemmed from weak validation of uploaded Python package code. An attacker could upload a package containing a malicious setup.py file, which would execute on the server during the installation process, leading to potential server compromise. No customer action is required. All customers have been automatically upgraded to the fixed version: 6.3.64 or higher.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Google Cloud | Google Cloud SecOps SOAR | 0 – through 6.3.64 |
Weakness: CWE-20 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:Clear