Vulnerability · Published Nov 11, 2025 · Assigned by NETGEAR
CVE-2025-12943Improper certificate validation in firmware update logic in NETGEAR RAX30 and RAXE300
Medium 5.2
In plain English
A medium-severity improper certificate validation in RAX30 from NETGEAR. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities).
Official description
Improper certificate validation in firmware update logic in NETGEAR RAX30 (Nighthawk AX5 5-Stream AX2400 WiFi 6 Router) and RAXE300 (Nighthawk AXE7800 Tri-Band WiFi 6E Router) allows attackers with the ability to intercept and tamper traffic destined to the device to execute arbitrary commands on the device. Devices with automatic updates enabled may already have this patch applied. If not, please check the firmware version and update to the latest. Fixed in: RAX30 firmware 1.0.14.108 or later. RAXE300 firmware 1.0.9.82 or later
Affected products (as reported)
Weakness: CWE-295 · Vector: CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U/AU:N/R:U/V:D/RE:L/U:Amber
References
- https://www.netgear.com/support/product/rax30 product, patch
- https://www.netgear.com/support/product/raxe300 product, patch
- https://kb.netgear.com/000070355/NETGEAR-Security-Advisories-November-2025 vendor-advisory