Vulnerability · Published Dec 9, 2025 · Assigned by Wordfence
CVE-2025-12705Social Reviews & Recommendations <= 2.5 - Unauthenticated Stored Cross-Site Scripting via Social Media Reviews
High 7.2
In plain English
A high-severity cross-site scripting in Reviews Widgets for Google, Yelp & TripAdvisor from widgetpack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities).
Official description
The Social Reviews & Recommendations plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in the 'trim_text' function in all versions up to, and including, 2.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.5.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| widgetpack | Reviews Widgets for Google, Yelp & TripAdvisor | 0 – through 2.5 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6d2aa302-aaab-4bf1-9a79-144290b967de?source=cve
- https://plugins.trac.wordpress.org/browser/fb-reviews-widget/trunk/includes/class-view.php#L447
- https://plugins.trac.wordpress.org/browser/fb-reviews-widget/trunk/includes/class-view.php#L449
- https://plugins.trac.wordpress.org/browser/fb-reviews-widget/trunk/includes/class-view.php#L452
- https://plugins.trac.wordpress.org/changeset/3393291/
- https://plugins.trac.wordpress.org/changeset/3406362/