Vulnerability · Published Oct 9, 2025 · Assigned by AMZN
CVE-2025-11573Denial of Service issue in Amazon.IonDotnet
High 7.5
In plain English
A high-severity security flaw in Amazon.IonDotnet from Amazon. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
An infinite loop issue in Amazon.IonDotnet library versions <v1.3.2 may allow a threat actor to cause a denial of service through a specially crafted text input. To mitigate this issue, users should upgrade to version v1.3.2. As of August 20, 2025, this library has been deprecated and will not receive further updates.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| NuGet | amazon.iondotnet | 1.3.2 | GHSA-q5r6-9qwq-g2wj |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Amazon | Amazon.IonDotnet | 0 – before 1.3.2 |
Weakness: CWE-1286 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/amazon-ion/ion-dotnet/releases/tag/v1.3.2 patch, product
- https://aws.amazon.com/security/security-bulletins/AWS-2025-022/ vendor-advisory
- https://github.com/amazon-ion/ion-dotnet/security/advisories/GHSA-q5r6-9qwq-g2wj third-party-advisory