Vulnerability · Published Jan 29, 2025 · Assigned by VulDB
CVE-2025-0840GNU Binutils objdump.c disassemble_bytes stack-based overflow
Medium 5.0
In plain English
A medium-severity stack buffer overflow in Binutils from GNU. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A vulnerability, which was classified as problematic, was found in GNU Binutils up to 2.43. This affects the function disassemble_bytes of the file binutils/objdump.c. The manipulation of the argument buf leads to stack-based buffer overflow. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 2.44 is able to address this issue. The identifier of the patch is baac6c221e9d69335bf41366a1c7d87d8ab2f893. It is recommended to upgrade the affected component.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | binutils | 2.42-r1 | ALPINE-CVE-2025-0840 |
| Alpine:v3.21 | binutils | 2.43.1-r2 | ALPINE-CVE-2025-0840 |
| Alpine:v3.22 | binutils | 2.44-r0 | ALPINE-CVE-2025-0840 |
| Alpine:v3.23 | binutils | 2.44-r0 | ALPINE-CVE-2025-0840 |
| Alpine:v3.24 | binutils | 2.44-r0 | ALPINE-CVE-2025-0840 |
| Debian:12 | binutils | no fix listed | DEBIAN-CVE-2025-0840 |
| Debian:13 | binutils | 2.43.90.20250122-1 | DEBIAN-CVE-2025-0840 |
| Debian:14 | binutils | 2.43.90.20250122-1 | DEBIAN-CVE-2025-0840 |
| Ubuntu:22.04:LTS | binutils | 2.38-4ubuntu2.7 | USN-7306-1 |
| Ubuntu:22.04:LTS | binutils | 2.38-4ubuntu2.11 | USN-7899-1 |
| Ubuntu:22.04:LTS | binutils | 2.38-4ubuntu2.7 | UBUNTU-CVE-2025-0840 |
| Ubuntu:24.04:LTS | binutils | 2.42-4ubuntu2.7 | USN-7899-1 |
| Ubuntu:24.04:LTS | binutils | 2.42-4ubuntu2.4 | USN-7306-1 |
| Ubuntu:24.04:LTS | binutils | 2.42-4ubuntu2.4 | UBUNTU-CVE-2025-0840 |
| Ubuntu:25.10 | binutils | 2.45-7ubuntu1.1 | USN-7899-1 |
Affected products (as reported)
Weakness: CWE-121, CWE-119 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
References
- VDB-293997 | GNU Binutils objdump.c disassemble_bytes stack-based overflow vdb-entry, technical-description
- VDB-293997 | CTI Indicators (IOB, IOC, IOA) signature, permissions-required
- Submit #485255 | GNU binutils/objdump 2.43 Buffer Overflow third-party-advisory
- https://sourceware.org/bugzilla/show_bug.cgi?id=32560 issue-tracking
- https://sourceware.org/bugzilla/attachment.cgi?id=15882 exploit
- https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=baac6c221e9d69335bf41366a1c7d87d8ab2f893 patch
- https://www.gnu.org/ product