Vulnerability · Published Mar 20, 2025 · Assigned by @huntr_ai
CVE-2025-0182Denial of Service in danswer-ai/danswer
High 7.5
In plain English
A high-severity resource allocation without limits in danswer-ai/danswer from danswer-ai. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities).
Official description
A vulnerability in danswer-ai/danswer version 0.9.0 allows for denial of service through memory exhaustion. The issue arises from the use of a vulnerable version of the starlette package (<=0.49) via fastapi, which was patched in fastapi version 0.115.3. The vulnerability can be exploited by sending multiple requests to the /auth/saml/callback endpoint, leading to uncontrolled memory consumption and eventual denial of service.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| danswer-ai | danswer-ai/danswer | unspecified – through latest |
Weakness: CWE-770 · Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H