Vulnerability · Published Sep 23, 2024 · Assigned by GitHub_P

CVE-2024-8263

Medium 6.2

In plain English

A medium-severity privilege mismanagement in GitHub Enterprise Server from GitHub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities).

Severity (CVSS 4.0)6.2Medium
Exploit odds (30 days)0.4%top 60.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

An improper privilege management vulnerability allowed arbitrary workflows to be committed using an improperly scoped PAT through the use of nested tags. This vulnerability affected all versions of GitHub Enterprise Server and was fixed in version 3.10.17, 3.11.15, 3.12.9, 3.13.4, and 3.14.1. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products (as reported)

VendorProductVersions
GitHub GitHub Enterprise Server 3.14 – through 3.14.03.13.0 – through 3.13.33.12.0 – through 3.12.83.11.0 – through 3.11.143.10.0 – through 3.10.16

Weakness: CWE-269 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:L/SI:H/SA:N

References