Vulnerability · Published Aug 9, 2024 · Assigned by ConcreteCMS

CVE-2024-7512Concrete CMS Stored XSS in Board instances

Medium 4.6

In plain English

A medium-severity improper input validation in Concrete CMS from Concrete CMS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)4.6Medium
Exploit odds (30 days)0.4%top 65.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Concrete CMS versions 9.0.0 through 9.3.2 are affected by a stored XSS vulnerability in Board instances. A rogue administrator could inject malicious code. The Concrete CMS security team gave this vulnerability a CVSS 4.0 Score of 4.6 with vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N. Versions below 9 are not affected. Thanks, m3dium for reporting. (CNA updated AC score to L based on CVSS 4.0 documentation)

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistconcrete5/concrete59.3.3GHSA-c47w-9mcf-w972

Affected products (as reported)

VendorProductVersions
Concrete CMS Concrete CMS 9.0.0 – through 9.3.2

Weakness: CWE-20 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

References