Vulnerability · Published Aug 8, 2024 · Assigned by VulDB

CVE-2024-7272FFmpeg swresample.c fill_audiodata heap-based overflow

Medium 6.3

In plain English

A medium-severity heap buffer overflow in FFmpeg. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)1.2%top 31.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ffmpeg7:5.1.6-0+deb12u1DEBIAN-CVE-2024-7272
Debian:12ffmpeg7:5.1.6-0+deb12u1DSA-5748-1
Debian:13ffmpeg7:6.0-4DEBIAN-CVE-2024-7272
Debian:14ffmpeg7:6.0-4DEBIAN-CVE-2024-7272
Ubuntu:24.04:LTSffmpeg7:6.0-6ubuntu1UBUNTU-CVE-2024-7272

Affected products (as reported)

VendorProductVersions
n/a FFmpeg 5.1.05.1.15.1.25.1.35.1.45.1.5

Weakness: CWE-122 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

References