Vulnerability · Published Aug 20, 2024 · Assigned by GitHub_P
CVE-2024-6337Incorrect Authorization allows read access to issues in GitHub Enterprise Server
Medium 5.9
In plain English
A medium-severity incorrect authorization in GitHub Enterprise Server from GitHub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities).
Official description
An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed a GitHub App with only content: read and pull_request_write: write permissions to read issue content inside a private repository. This was only exploitable via user access token and installation access token was not impacted. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.13.3, 3.12.8, 3.11.14 and 3.10.16. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| GitHub | GitHub Enterprise Server | 3.10.0 – through 3.10.153.11.0 – through 3.11.143.12.0 – through 3.12.73.13.0 – through 3.13.2 |
Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N/S:N
References
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.16
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.14
- https://docs.github.com/en/enterprise-server@3.12/admin/release-notes#3.12.8
- https://docs.github.com/en/enterprise-server@3.13/admin/release-notes#3.13.3