Vulnerability · Published Jun 15, 2024 · Assigned by Wordfence
CVE-2024-6000FooEvents for WooCommerce <= 1.19.20 - Improper Authorization to (Contributor+) Arbitrary File Upload
High 7.1
In plain English
A high-severity security flaw in FooEvents for WooCommerce from FooEvents. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities).
Official description
The FooEvents for WooCommerce plugin for WordPress is vulnerable to unauthorized arbitrary file uploads due to an improper capability setting on the 'display_ticket_themes_page' function in versions up to, and including, 1.19.20. This makes it possible for authenticated attackers with contributor-level capabilities or above, to upload arbitrary files on the affected site's server which may make remote code execution possible. This was partially patched in 1.19.20, and fully patched in 1.19.21.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| FooEvents | FooEvents for WooCommerce | 0 – through 1.19.20 |
Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H