Vulnerability · Published Jun 21, 2024 · Assigned by Wordfence
CVE-2024-5945WP SVG Images <= 4.3 - Authenticated (Author+) Stored Cross-Site Scripting via SVG
Medium 6.4
In plain English
A medium-severity cross-site scripting in WP SVG Images from shortpixel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities).
Official description
The WP SVG Images plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘type’ parameter in all versions up to, and including, 4.3 due to insufficient input sanitization. This makes it possible for authenticated attackers, with Author-level access and above, who have permissions to upload sanitized files, to bypass SVG sanitization and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A bypass to the patch in version 4.3 was discovered and fixed completely in version 4.4.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| shortpixel | WP SVG Images | 0 – through 4.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/389d96e9-1fad-49a6-89b6-8f7f108d8117?source=cve
- https://plugins.trac.wordpress.org/browser/wp-svg-images/trunk/wp-svg-images.php#L111
- https://plugins.trac.wordpress.org/browser/wp-svg-images/trunk/wp-svg-images.php#L313
- https://plugins.trac.wordpress.org/changeset/3105276/
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3227378%40wp-svg-images&new=3227378%40wp-svg-images&sfp_email=&sfph_mail=