Vulnerability · Published Dec 11, 2024 · Assigned by apple

CVE-2024-54505

High 8.8

In plain English

A high-severity type confusion in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)1.1%top 35.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A type confusion issue was addressed with improved memory handling. This issue is fixed in Safari 18.2, iOS 18.2 and iPadOS 18.2, iPadOS 17.7.3, macOS Sequoia 15.2, tvOS 18.2, visionOS 2.2, watchOS 11.2. Processing maliciously crafted web content may lead to memory corruption.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.46.5-1.el8_10ALSA-2025:0145
AlmaLinux:9webkit2gtk32.46.5-1.el9_5ALSA-2025:0146
AlmaLinux:8webkit2gtk3-devel2.46.5-1.el8_10ALSA-2025:0145
AlmaLinux:9webkit2gtk3-devel2.46.5-1.el9_5ALSA-2025:0146
AlmaLinux:8webkit2gtk3-jsc2.46.5-1.el8_10ALSA-2025:0145
AlmaLinux:9webkit2gtk3-jsc2.46.5-1.el9_5ALSA-2025:0146
AlmaLinux:8webkit2gtk3-jsc-devel2.46.5-1.el8_10ALSA-2025:0145
AlmaLinux:9webkit2gtk3-jsc-devel2.46.5-1.el9_5ALSA-2025:0146
Debian:12webkit2gtk2.46.5-1~deb12u1DEBIAN-CVE-2024-54505
Debian:12webkit2gtk2.46.5-1~deb12u1DSA-5835-1
Debian:13webkit2gtk2.46.5-1DEBIAN-CVE-2024-54505
Debian:14webkit2gtk2.46.5-1DEBIAN-CVE-2024-54505
Debian:12wpewebkitno fix listedDEBIAN-CVE-2024-54505
Debian:13wpewebkit2.46.5-1DEBIAN-CVE-2024-54505
Debian:14wpewebkit2.46.5-1DEBIAN-CVE-2024-54505
Rocky Linux:8webkit2gtk30:2.46.5-1.el8_10RLSA-2025:0145
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2024-54505
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2024-54505
Ubuntu:22.04:LTSwebkit2gtk2.46.5-0ubuntu0.22.04.1USN-7201-1
Ubuntu:22.04:LTSwebkit2gtk2.46.5-0ubuntu0.22.04.1UBUNTU-CVE-2024-54505
Ubuntu:24.04:LTSwebkit2gtk2.46.5-0ubuntu0.24.04.1UBUNTU-CVE-2024-54505
Ubuntu:24.04:LTSwebkit2gtk2.46.5-0ubuntu0.24.04.1USN-7201-1
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2024-54505

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 18.2
Apple iOS and iPadOS 0 – before 18.2
Apple iPadOS 0 – before 17.7.3
Apple macOS 0 – before 15.2
Apple tvOS 0 – before 18.2
Apple visionOS 0 – before 2.2
Apple watchOS 0 – before 11.2

Weakness: CWE-843 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References