Vulnerability · Published Dec 10, 2024 · Assigned by GitHub_M
CVE-2024-54152Angular Expressions - Remote Code Execution when using locals
Critical 9.3
In plain English
A critical-severity code injection in angular-expressions from peerigon. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.2% (higher than 83% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Angular Expressions provides expressions for the Angular.JS web framework as a standalone module. Prior to version 1.4.3, an attacker can write a malicious expression that escapes the sandbox to execute arbitrary code on the system. With a more complex (undisclosed) payload, one can get full access to Arbitrary code execution on the system. The problem has been patched in version 1.4.3 of Angular Expressions. Two possible workarounds are available. One may either disable access to `__proto__` globally or make sure that one uses the function with just one argument.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Ubuntu:22.04:LTS | angular.js | no fix listed | UBUNTU-CVE-2024-54152 |
| Ubuntu:24.04:LTS | angular.js | no fix listed | UBUNTU-CVE-2024-54152 |
| Ubuntu:25.10 | angular.js | no fix listed | UBUNTU-CVE-2024-54152 |
| npm | angular-expressions | 1.4.3 | GHSA-5462-4vcx-jh7j |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| peerigon | angular-expressions | < 1.4.3 |
Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N