Vulnerability · Published Dec 2, 2024 · Assigned by GitHub_M
CVE-2024-53989Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0
Low 2.3
In plain English
A low-severity cross-site scripting in rails-html-sanitizer from rails. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. There is a possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer 1.6.0 when used with Rails >= 7.1.0. A possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer may allow an attacker to inject content if HTML5 sanitization is enabled and the application developer has overridden the sanitizer's allowed tags for the the "noscript" element. This vulnerability is fixed in 1.6.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| RubyGems | rails-html-sanitizer | 1.6.1 | GHSA-rxv5-gxqc-xx8g |
| Ubuntu:22.04:LTS | ruby-rails-html-sanitizer | no fix listed | UBUNTU-CVE-2024-53989 |
| Ubuntu:24.04:LTS | ruby-rails-html-sanitizer | no fix listed | UBUNTU-CVE-2024-53989 |
| Ubuntu:25.10 | ruby-rails-html-sanitizer | no fix listed | UBUNTU-CVE-2024-53989 |
| Ubuntu:26.04:LTS | ruby-rails-html-sanitizer | no fix listed | UBUNTU-CVE-2024-53989 |
| Ubuntu:26.10 | ruby-rails-html-sanitizer | no fix listed | UBUNTU-CVE-2024-53989 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| rails | rails-html-sanitizer | >= 1.6.0, < 1.6.1 |
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N